RFR: 8175094: Mark the deprecated java.security.acl APIs with forRemoval=true

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

RFR: 8175094: Mark the deprecated java.security.acl APIs with forRemoval=true

Sean Mullan
Please review this JDK 10 change to mark the deprecated
java.security.acl APIs with forRemoval=true. These APIs will be removed
from a subsequent version of Java SE. They have been deprecated since
JDK 9 and superseded by classes in java.security since 1.2. It is no
longer necessary to retain these classes.

webrev: http://cr.openjdk.java.net/~mullan/webrevs/8175094/webrev.00/
issue: https://bugs.openjdk.java.net/browse/JDK-8175094

--Sean