RFR: 8186478: [JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

RFR: 8186478: [JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

Doug Simon @ Oracle
Please review this small change to fix the spelling of a method's name.

https://bugs.openjdk.java.net/browse/JDK-8186478
http://cr.openjdk.java.net/~dnsimon/8186478

-Doug
Reply | Threaded
Open this post in threaded view
|

Re: RFR: 8186478: [JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

Vladimir Kozlov
Looks good.
But why you need to rename it? There is no explanation in JBS. Please,
add it.

Thanks,
Vladimir

On 11/3/17 8:55 AM, Doug Simon wrote:
> Please review this small change to fix the spelling of a method's name.
>
> https://bugs.openjdk.java.net/browse/JDK-8186478
> http://cr.openjdk.java.net/~dnsimon/8186478
>
> -Doug
>
Reply | Threaded
Open this post in threaded view
|

Re: RFR: 8186478: [JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

Doug Simon @ Oracle
I added a justification to the bug which is copied below:

This method should be renamed to setNotInlinableOrCompilable for better consistency with existing OpenJDK source. Grepping through the sources available from  http://hg.openjdk.java.net/jdk10/hs: 

dsimon@kruger-4 ~/j/open> ag -i inlineable | grep -v setNotInlineableOrCompileable | wc -l
     107
dsimon@kruger-4 ~/j/open> ag -i inlinable | grep -v setNotInlineableOrCompileable | wc -l
      24
dsimon@kruger-4 ~/j/open> ag -i compileable | grep -v setNotInlineableOrCompileable | wc -l
       3
dsimon@kruger-4 ~/j/open> ag -i compilable | grep -v setNotInlineableOrCompileable | wc -l
     585

Based purely on these frequencies, we could rename to setNotInlineableOrCompilable but that looks internally inconsistent (why drop e from one word and not the other?).

-Doug

> On 3 Nov 2017, at 20:03, Vladimir Kozlov <[hidden email]> wrote:
>
> Looks good.
> But why you need to rename it? There is no explanation in JBS. Please, add it.
>
> Thanks,
> Vladimir
>
> On 11/3/17 8:55 AM, Doug Simon wrote:
>> Please review this small change to fix the spelling of a method's name.
>> https://bugs.openjdk.java.net/browse/JDK-8186478
>> http://cr.openjdk.java.net/~dnsimon/8186478
>> -Doug

Reply | Threaded
Open this post in threaded view
|

Re: RFR: 8186478: [JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

Vladimir Kozlov
I originally thought it is related to original changes JDK-8180487 and
compatibility with jdk 9. But it looks like you simple fixed wording.

Looks good.

Thanks,
Vladimir

On 11/3/17 2:11 PM, Doug Simon wrote:

> I added a justification to the bug which is copied below:
>
> This method should be renamed to setNotInlinableOrCompilable for better consistency with existing OpenJDK source. Grepping through the sources available from  http://hg.openjdk.java.net/jdk10/hs:
>
> dsimon@kruger-4 ~/j/open> ag -i inlineable | grep -v setNotInlineableOrCompileable | wc -l
>       107
> dsimon@kruger-4 ~/j/open> ag -i inlinable | grep -v setNotInlineableOrCompileable | wc -l
>        24
> dsimon@kruger-4 ~/j/open> ag -i compileable | grep -v setNotInlineableOrCompileable | wc -l
>         3
> dsimon@kruger-4 ~/j/open> ag -i compilable | grep -v setNotInlineableOrCompileable | wc -l
>       585
>
> Based purely on these frequencies, we could rename to setNotInlineableOrCompilable but that looks internally inconsistent (why drop e from one word and not the other?).
>
> -Doug
>
>> On 3 Nov 2017, at 20:03, Vladimir Kozlov <[hidden email]> wrote:
>>
>> Looks good.
>> But why you need to rename it? There is no explanation in JBS. Please, add it.
>>
>> Thanks,
>> Vladimir
>>
>> On 11/3/17 8:55 AM, Doug Simon wrote:
>>> Please review this small change to fix the spelling of a method's name.
>>> https://bugs.openjdk.java.net/browse/JDK-8186478
>>> http://cr.openjdk.java.net/~dnsimon/8186478
>>> -Doug
>
Reply | Threaded
Open this post in threaded view
|

Re: RFR: 8186478: [JVMCI] rename HotSpotResolvedJavaMethod#setNotInlineableOrCompileable

Tobias Hartmann-2
In reply to this post by Doug Simon @ Oracle
Hi Doug,

looks good to me.

Best regards,
Tobias

On 03.11.2017 16:55, Doug Simon wrote:
> Please review this small change to fix the spelling of a method's name.
>
> https://bugs.openjdk.java.net/browse/JDK-8186478
> http://cr.openjdk.java.net/~dnsimon/8186478
>
> -Doug
>