Re: [11] RFR (XS) 8193838: Update jtreg requiredVersion to 4.2 b11 for JDK 11 and 12 support

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [11] RFR (XS) 8193838: Update jtreg requiredVersion to 4.2 b11 for JDK 11 and 12 support

David Holmes
Thanks Serguei!

David

On 20/12/2017 8:41 PM, [hidden email] wrote:

> David,
>
> It looks good.
>
> Thanks,
> Serguei
>
>
> On 12/20/17 02:22, David Holmes wrote:
>> Before we can update to JDK version 11, jtreg needs to be updated to
>> recognize that release value - which is happening in jtreg 4.2 b11. So
>> we then need to ensure that jtreg 4.2 b11 is used by updating the
>> requiredVersion in each of the TEST.ROOT files, and in the jib
>> configuiration.
>>
>> bug: https://bugs.openjdk.java.net/browse/JDK-8193838
>> webrev: http://cr.openjdk.java.net/~dholmes/8193838/webrev/
>>
>> Testing - TBD once b11 is promoted
>>  - local build using jib
>>  - hs/jdk tier1 and tier2
>>
>> Thanks,
>> David
>